QTfrontend/CMakeLists.txt
changeset 8104 09c38cdf380d
parent 8083 2edbd01a04a0
child 8126 5bfa1b2025d6
child 8144 f3ba33d5d2b1
--- a/QTfrontend/CMakeLists.txt	Thu Nov 22 23:20:56 2012 +0400
+++ b/QTfrontend/CMakeLists.txt	Fri Nov 23 10:43:15 2012 +0100
@@ -163,8 +163,13 @@
     link_directories(${EXECUTABLE_OUTPUT_PATH})
 endif()
 
+#when debugging, always prompt a console to see fronted messages
+#TODO: check it doesn't interfere on UNIX
+if(CMAKE_BUILD_TYPE MATCHES "RELEASE")
+    set(console_access "WIN32")
+endif(CMAKE_BUILD_TYPE MATCHES "RELEASE")
 
-add_executable(hedgewars WIN32
+add_executable(hedgewars ${console_access}
     ${hwfr_src}
     ${hwfr_moc_srcs}
     ${hwfr_hdrs}