CMakeLists.txt
branchphysfslayer
changeset 8522 1853628ae285
parent 8348 c039ac6f33e0
child 8528 ffd71e99a4f0
--- a/CMakeLists.txt	Fri Feb 22 05:05:32 2013 +0100
+++ b/CMakeLists.txt	Fri Feb 22 05:15:48 2013 +0100
@@ -268,10 +268,13 @@
 
 
 #physfs library (static on unix, dll on win32)
-add_subdirectory(misc/physfs)
-if(NOT WIN32)
-    list(APPEND pascal_flags "-k${LIBRARY_OUTPUT_PATH}/libphysfs.a")
+find_package(PhysFS)
+if(PHYSFS_FOUND EQUAL FALSE)
+    add_subdirectory(misc/physfs)
 endif()
+#    if(NOT WIN32)
+#        list(APPEND pascal_flags "-k${LIBRARY_OUTPUT_PATH}/libphysfs.a")
+#    endif()
 
 
 #main engine