hedgewars/CMakeLists.txt
changeset 1744 19a0016af2a2
parent 1415 6fbfee0e113a
child 1806 3c4f0886c123
--- a/hedgewars/CMakeLists.txt	Sat Jan 24 12:43:57 2009 +0000
+++ b/hedgewars/CMakeLists.txt	Sat Jan 24 12:48:32 2009 +0000
@@ -73,7 +73,11 @@
 		message("Minimum required version of FreePascal is 2.2.0")
 	else (fpc_ver LESS "020200")
 		set(pascal_compiler ${fpc_executable})
-		set(pascal_compiler_flags ${noexecstack_flags} "-B" "-FE../bin" "-Cs2000000" "-vwi" "-O2" ${hwengine_project})
+		IF(APPLE)
+			set(pascal_compiler_flags ${noexecstack_flags} "-B" "-FE../bin" "-Cs2000000" "-vwi" "-O2" "-Fl/opt/local/lib" ${hwengine_project})
+		ELSE(APPLE)
+			set(pascal_compiler_flags ${noexecstack_flags} "-B" "-FE../bin" "-Cs2000000" "-vwi" "-O2" ${hwengine_project})
+		ENDIF(APPLE)
 	endif (fpc_ver LESS "020200")
 endif (fpc_version)