CMakeLists.txt
branchcmake_pascal
changeset 8781 1b22d13afbc7
parent 8775 3cad01db0bae
child 8784 c11727e5fa3f
--- a/CMakeLists.txt	Tue Mar 19 10:35:10 2013 +0100
+++ b/CMakeLists.txt	Tue Mar 19 10:39:05 2013 +0100
@@ -30,7 +30,7 @@
 option(ANDROID "Enable Android build (off)" OFF)
 
 if(UNIX AND NOT APPLE)
-    option(MINIMAL_FLAGS "Respect system flags as much as possible (off)" OFF)
+    option(MINIMAL_CFLAGS "Respect system CFLAGS as much as possible (off)" OFF)
 else()
     option(NOAUTOUPDATE "Disable OS X Sparkle update checking" OFF)
 endif()
@@ -207,8 +207,8 @@
 endif (CMAKE_BUILD_TYPE)
 
 
-#set default flags values for all projects (unless MINIMAL_FLAGS is true)
-if(NOT ${MINIMAL_FLAGS})
+#set default flags values for all projects (unless MINIMAL_CFLAGS is true)
+if(NOT ${MINIMAL_CFLAGS})
     set(CMAKE_C_FLAGS "-pipe ${CMAKE_C_FLAGS}")
     set(CMAKE_C_FLAGS_RELEASE "-w -Os -fomit-frame-pointer ${CMAKE_C_FLAGS_RELEASE}")
     set(CMAKE_C_FLAGS_DEBUG "-Wall -O0 -g -DDEBUG ${CMAKE_C_FLAGS_DEBUG}")
@@ -229,7 +229,7 @@
 check_c_compiler_flag("" HAVE_NOEXECSTACK) #empty because we are testing a linker flag
 if(HAVE_NOEXECSTACK)
     add_flag_append(CMAKE_Pascal_FLAGS "-k-z -knoexecstack")
-    if(NOT ${MINIMAL_FLAGS})
+    if(NOT ${MINIMAL_CFLAGS})
         set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${CMAKE_REQUIRED_FLAGS}")
     endif()
 endif()