hedgewars/CMakeLists.txt
changeset 8518 24d2bdc6deff
parent 8379 6a446b7cece0
child 8528 ffd71e99a4f0
--- a/hedgewars/CMakeLists.txt	Tue Feb 19 22:03:33 2013 +0400
+++ b/hedgewars/CMakeLists.txt	Wed Feb 20 01:55:23 2013 +0100
@@ -146,6 +146,10 @@
 
         list(APPEND pascal_flags "-k${SDLMAIN_LIB}")
     endif()
+
+    #when you have multiple ld installation make sure you get the one bundled with the compiler
+    get_filename_component(compiler_dir ${CMAKE_C_COMPILER} PATH)
+    list(APPEND pascal_flags "-FD${compiler_dir}")
 endif(APPLE)
 
 if(NOT NOPNG)