CMakeLists.txt
changeset 14263 29d614a5c9eb
parent 14147 89acfded7722
child 14356 c2712b142e9d
--- a/CMakeLists.txt	Wed Nov 21 11:59:20 2018 -0500
+++ b/CMakeLists.txt	Wed Nov 21 12:41:55 2018 -0500
@@ -72,6 +72,9 @@
 if("${CMAKE_SIZEOF_VOID_P}" EQUAL "4" AND UNIX AND NOT APPLE)
     set(BUILD_ENGINE_C ON CACHE STRING "PAS2C force-enabled due to a freepascal 32 bit alignment bug" FORCE)
 endif()
+if(BUILD_ENGINE_C)
+    set(NOVIDEOREC ON CACHE STRING "PAS2C does not support video recording at present" FORCE)
+endif()
 
 #system paths for finding required fonts (see share/hedgewars/Data/fonts)
 #subdirectories will NOT be searched.