CMakeLists.txt
changeset 7264 4c438ad3eddc
parent 7256 5b97b9946cde
child 7397 833fc211ca2d
--- a/CMakeLists.txt	Mon Jun 18 23:45:21 2012 +0400
+++ b/CMakeLists.txt	Tue Jun 19 00:40:52 2012 +0400
@@ -208,7 +208,11 @@
     message(STATUS "Lua library not found, building bundled dependency")
     add_subdirectory(misc/liblua)
     #linking with liblua.a requires system readline -- this works everywhere, right?
-    set(pascal_flags "-k${CMAKE_BINARY_DIR}/bin/liblua.a" "-k-lreadline" ${pascal_flags})
+    if(WIN32)
+        set(pascal_flags "-k${CMAKE_BINARY_DIR}/bin/liblua.dll.a" "-k-lreadline" ${pascal_flags})
+    else()
+        set(pascal_flags "-k${CMAKE_BINARY_DIR}/bin/liblua.a" "-k-lreadline" ${pascal_flags})
+    endif()
 endif()
 
 add_subdirectory(hedgewars)