tools/CMakeLists.txt
changeset 8322 50369fa5053b
parent 8317 ec9f94ab2737
child 8659 e49056d3aba1
--- a/tools/CMakeLists.txt	Sat Dec 22 21:43:39 2012 -0500
+++ b/tools/CMakeLists.txt	Mon Dec 24 03:00:18 2012 +0100
@@ -37,6 +37,11 @@
     endif()
 
     set(frameworks_dir ${CMAKE_INSTALL_PREFIX}/${target_library_install_dir})
+    if(${BUILD_ENGINE_LIBRARY})
+        set(engine_full_path "${frameworks_dir}/${CMAKE_SHARED_LIBRARY_PREFIX}hwengine${CMAKE_SHARED_LIBRARY_SUFFIX}")
+    else()
+        set(engine_full_path "${CMAKE_INSTALL_PREFIX}/hwengine${CMAKE_EXECUTABLE_SUFFIX}")
+    endif()
 
     #this tool is present in qt 4.5 but only if you compile from sources
     #from qt 4.6 is present also in the binary version