CMakeLists.txt
branchcmake_pascal
changeset 8770 53481d654691
parent 8734 ecb0a97100cf
child 8775 3cad01db0bae
--- a/CMakeLists.txt	Tue Mar 19 00:30:48 2013 +0100
+++ b/CMakeLists.txt	Tue Mar 19 01:28:25 2013 +0100
@@ -331,7 +331,7 @@
     #-XLA is a beta fpc flag that renames libraries before passing them to the linker
     #we also have to pass PHYSFS_INTERNAL to satisfy windows runtime requirements
     #(should be harmless on other platforms)
-    list(APPEND pascal_flags "-XLAphysfs=${physfs_output_name}" "-dPHYSFS_INTERNAL")
+    set(CMAKE_Pascal_FLAGS "-XLAphysfs=${physfs_output_name} -dPHYSFS_INTERNAL ${CMAKE_Pascal_FLAGS}")
 endif()
 
 find_package_or_disable_msg(FFMPEG NOVIDEOREC "Video recording will not be built")