CMakeLists.txt
changeset 8687 5b6ad1bd6ace
parent 8686 d303da4568b7
child 8688 88a6114a318c
--- a/CMakeLists.txt	Thu Mar 07 10:14:12 2013 +0100
+++ b/CMakeLists.txt	Thu Mar 07 10:16:21 2013 +0100
@@ -19,17 +19,19 @@
 
 
 #possible cmake configuration
-option(NOSERVER "Disable gameServer build [default: off]" OFF)
-option(NOPNG "Disable screenshoot compression [default: off]" OFF)
-option(NOVIDEOREC "Disable video recording [default: off]" OFF)
+option(NOSERVER "Disable gameServer build (off)]" OFF)
+option(NOPNG "Disable screenshoot compression (off)" OFF)
+option(NOVIDEOREC "Disable video recording (off)" OFF)
 
 #set this to ON when 2.1.0 becomes more widespread (and only for linux)
-option(SYSTEM_PHYSFS "Use system physfs [default:off]" OFF)
+option(SYSTEM_PHYSFS "Use system physfs (off)" OFF)
 
-option(BUILD_ENGINE_LIBRARY "Enable hwengine library [default: off]" OFF)
-option(ANDROID "Enable Android build [default: off]" OFF)
-option(MINIMAL_FLAGS "Respect system flags as much as possible [default: off]" OFF)
-if(APPLE)
+option(BUILD_ENGINE_LIBRARY "Enable hwengine library (off)" OFF)
+option(ANDROID "Enable Android build (off)" OFF)
+
+if(UNIX AND NOT APPLE)
+    option(MINIMAL_FLAGS "Respect system flags as much as possible (off)" OFF)
+else()
     option(NOAUTOUPDATE "Disable OS X Sparkle update checking" OFF)
 endif()