project_files/hwc/CMakeLists.txt
branch1.0.0
changeset 15859 7b1d6dfa3173
parent 15362 c8f37fc9c266
child 15962 4013354585be
--- a/project_files/hwc/CMakeLists.txt	Wed Sep 07 16:54:58 2022 -0400
+++ b/project_files/hwc/CMakeLists.txt	Mon Sep 12 10:40:53 2022 -0400
@@ -1,6 +1,6 @@
 #the usual set of dependencies
 find_package(OpenGL REQUIRED)
-find_package(SDL2 REQUIRED)
+find_package(SDL2 REQUIRED CONFIG)
 find_package(SDL2_mixer 2 REQUIRED)
 find_package(SDL2_net 2 REQUIRED)
 find_package(SDL2_image 2 REQUIRED)
@@ -111,7 +111,7 @@
 target_link_libraries(hwengine  fpcrtl
                                 ${LUA_LIBRARY}
                                 ${OPENGL_LIBRARY}
-                                ${SDL2_LIBRARY}
+                                ${SDL2_LIBRARIES}
                                 ${SDL2_MIXER_LIBRARIES}
                                 ${SDL2_NET_LIBRARIES}
                                 ${SDL2_IMAGE_LIBRARIES}