CMakeLists.txt
changeset 9994 8455993a7a1b
parent 9991 3858d99476f5
child 10004 eb0b520564bb
--- a/CMakeLists.txt	Thu Jan 16 17:18:53 2014 +0100
+++ b/CMakeLists.txt	Thu Jan 16 19:50:18 2014 +0100
@@ -21,6 +21,13 @@
 #set this to ON when 2.1.0 becomes more widespread (and only for linux)
 option(PHYSFS_SYSTEM "Use system physfs (off)" OFF)
 
+#system paths for finding required fonts (see share/hedgewars/Data/fonts)
+#subdirectories will NOT be searched.
+#all founds that can't be found will be bundled with hedgewars
+option(PHYSFS_SYSTEM "Use system physfs (off)" OFF)
+
+option(BUILD_SHARED_LIBS "Build libraries as shared modules (on)" ON)
+
 if(WIN32 OR APPLE)
     option(LUA_SYSTEM "Use system lua (off)" OFF)
 else()
@@ -38,6 +45,7 @@
     set(DATA_INSTALL_DIR "share/hedgewars" CACHE STRING "Resource folder path")
 endif()
 
+set(FONTS_DIRS "" CACHE STRING "Additional paths to folders where required fonts can be found ( ; is separator)")
 
 #versioning
 set(CPACK_PACKAGE_VERSION_MAJOR 0)