project_files/hwc/CMakeLists.txt
branchwebgl
changeset 9259 872dd30deb7b
parent 9256 5a2e94a4c2d0
child 9267 dbd18257be8f
--- a/project_files/hwc/CMakeLists.txt	Tue Jun 18 22:10:51 2013 +0200
+++ b/project_files/hwc/CMakeLists.txt	Tue Jun 18 22:39:57 2013 +0200
@@ -25,6 +25,11 @@
 list(REMOVE_ITEM engine_sources_pas "${CMAKE_SOURCE_DIR}/hedgewars/pas2cRedo.pas")
 list(REMOVE_ITEM engine_sources_pas "${CMAKE_SOURCE_DIR}/hedgewars/hwLibrary.pas")
 
+#remove and readd hwengine so that it is compiled first, compiling every other file in the process
+list(REMOVE_ITEM engine_sources_pas ${CMAKE_SOURCE_DIR}/hedgewars/hwengine.pas)
+list(APPEND engine_sources_pas ${CMAKE_SOURCE_DIR}/hedgewars/hwengine.pas)
+
+#process files .pas -> .c
 foreach(sourcefile ${engine_sources_pas})
     get_filename_component(sourcename ${sourcefile} NAME_WE) #drops .pas
     list(APPEND engine_sources "${CMAKE_CURRENT_BINARY_DIR}/${sourcename}.c")