tools/CMakeLists.txt
changeset 11271 a292efd31bde
parent 10976 56f07b52213a
child 11362 ed5a6478e710
--- a/tools/CMakeLists.txt	Tue Nov 03 00:51:11 2015 +0100
+++ b/tools/CMakeLists.txt	Tue Nov 03 01:14:27 2015 +0100
@@ -58,7 +58,7 @@
 
     #create the .dmg for deployment
     #first make sure .app exists, then remove any old .dmg with same name, finally run the script
-    add_custom_target(dmg COMMAND "if [ ! -a Hedgewars.app ]; then make install\; fi;"
+    add_custom_target(dmg COMMAND make install
                           COMMAND rm -f ${CMAKE_BINARY_DIR}/Hedgewars-${HEDGEWARS_VERSION}.dmg
                           COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/create-dmg.sh
                                   --volname "Hedgewars ${HEDGEWARS_VERSION}"