hedgewars/CMakeLists.txt
branch0.9.18
changeset 7954 a5f0a6d46c52
parent 7942 17b3937de37b
child 8018 091293bc974f
child 8019 b216953c2617
--- a/hedgewars/CMakeLists.txt	Mon Nov 05 17:11:28 2012 -0500
+++ b/hedgewars/CMakeLists.txt	Wed Nov 07 05:17:07 2012 +0100
@@ -208,6 +208,11 @@
     set(FFMPEG_FIND_QUIETLY true)
     find_package(FFMPEG)
     if(${FFMPEG_FOUND})
+        # TODO: this check is only for SDL < 2
+        # fpc will take care of linking but we need to have this library installed
+        find_package(GLUT REQUIRED)
+
+        #TODO: convert avwrapper to .pas unit so we can skip this step
         include_directories(${FFMPEG_INCLUDE_DIR})
         set(pascal_flags "-dUSE_VIDEO_RECORDING" ${pascal_flags})
         IF (WIN32)
@@ -265,7 +270,7 @@
 endif()
 
 #when ffmpeg/libav is found we need to compile it before engine
-#TODO: convert avwrapper to .pas unit so we can skip this
+#TODO: convert avwrapper to .pas unit so we can skip this step
 if(${FFMPEG_FOUND})
     add_dependencies(${engine_output_name} avwrapper)
 endif()