CMakeLists.txt
changeset 8671 a9957b7797f3
parent 8669 3f9853888d4f
child 8672 4cccc0520988
--- a/CMakeLists.txt	Wed Mar 06 09:42:20 2013 -0500
+++ b/CMakeLists.txt	Wed Mar 06 16:40:56 2013 +0100
@@ -284,28 +284,6 @@
 endif()
 
 
-
-#server discovery
-if(NOT NOSERVER)
-    if(GHC)
-        set(ghc_executable ${GHC})
-    else()
-        find_program(ghc_executable ghc)
-    endif()
-
-    if(ghc_executable)
-        add_subdirectory(gameServer)
-        message(STATUS "Found GHC: ${ghc_executable}")
-    else()
-        message(${WARNING} "Could NOT find GHC, server will not be built")
-        set(HAVE_NETSERVER false)
-    endif()
-else()
-    message(STATUS "Server will not be built per user request")
-    set(HAVE_NETSERVER false)
-endif()
-
-
 #lua discovery
 find_package(Lua)
 if(LUA_FOUND)
@@ -362,9 +340,14 @@
     set(FFMPEG_FOUND false)
 endif()
 
-#
+#physfs helper library
 add_subdirectory(misc/libphyslayer)
 
+#server
+if(NOT NOSERVER)
+    add_subdirectory(gameServer)
+endif()
+
 #main engine
 add_subdirectory(hedgewars)