QTfrontend/CMakeLists.txt
branchwebgl
changeset 9270 a9b9ebd3d3be
parent 9244 bb95e351270c
child 9521 8054d9d775fd
--- a/QTfrontend/CMakeLists.txt	Wed Jun 19 00:52:39 2013 +0400
+++ b/QTfrontend/CMakeLists.txt	Wed Jun 19 00:07:31 2013 +0200
@@ -57,6 +57,7 @@
 include_directories(${SDLMIXER_INCLUDE_DIR})
 include_directories(${PHYSFS_INCLUDE_DIR})
 include_directories(${PHYSLAYER_INCLUDE_DIR})
+include_directories(${LUA_INCLUDE_DIR}) #brought by physlayer hwpacksmounter.h
 
 
 if(UNIX)
@@ -209,6 +210,11 @@
         )
 endif()
 
+if(CMAKE_CXX_COMPILER MATCHES "clang*")
+    list(APPEND HW_LINK_LIBS stdc++)
+endif()
+
+
 target_link_libraries(hedgewars ${HW_LINK_LIBS})