CMakeLists.txt
changeset 7704 b25add2fdfa6
parent 7397 833fc211ca2d
child 7705 15f5d3cd35c6
--- a/CMakeLists.txt	Sat Sep 22 19:14:58 2012 +0400
+++ b/CMakeLists.txt	Tue Sep 25 00:35:49 2012 +0200
@@ -217,11 +217,7 @@
     message(STATUS "Lua library not found, building bundled dependency")
     add_subdirectory(misc/liblua)
     #linking with liblua.a requires system readline -- this works everywhere, right?
-    if(WIN32)
-        set(pascal_flags "-k${CMAKE_BINARY_DIR}/bin/liblua.dll.a" "-k-lreadline" ${pascal_flags})
-    else()
-        set(pascal_flags "-k${CMAKE_BINARY_DIR}/bin/liblua.a" "-k-lreadline" ${pascal_flags})
-    endif()
+    set(pascal_flags "-k${EXECUTABLE_OUTPUT_PATH}/lib${LUA_LIBRARY}.a" "-k-lreadline" ${pascal_flags})
 endif()
 
 add_subdirectory(hedgewars)