QTfrontend/CMakeLists.txt
changeset 9519 b8b5c82eb61b
parent 9225 d8d929f92633
child 9521 8054d9d775fd
child 9650 1c7c87ce37fd
--- a/QTfrontend/CMakeLists.txt	Fri Oct 11 00:04:36 2013 +0200
+++ b/QTfrontend/CMakeLists.txt	Fri Oct 11 00:07:23 2013 +0200
@@ -13,6 +13,12 @@
 find_package(Qt4 REQUIRED)
 include(${QT_USE_FILE})
 
+if(APPLE AND
+   ${QTVERSION} VERSION_GREATER "4.7.0" AND
+   ${QTVERSION} VERSION_LESS "4.7.4")
+    message(FATAL_ERROR "This version of QT is known *not* to work, please update or use a lower version")
+endif()
+
 find_package(SDL REQUIRED)       #video in SDLInteraction
 find_package(SDL_mixer REQUIRED) #audio in SDLInteraction