CMakeLists.txt
changeset 9214 bcb103c0a34a
parent 9213 e3d46d0bc7d0
child 9220 5e7db24f3489
--- a/CMakeLists.txt	Wed Jun 12 16:43:24 2013 +0200
+++ b/CMakeLists.txt	Wed Jun 12 16:44:53 2013 +0200
@@ -152,7 +152,9 @@
         message(FATAL_ERROR "Missing Lua! Rerun cmake with -DLUA_SYSTEM=off to build the internal version")
     endif()
 else()
-    message(STATUS "LUA will be provided by the bundled sources")
+    if (NOT LUA_LIBRARY OR NOT LUA_INCLUDE_DIR)
+        message(STATUS "LUA will be provided by the bundled sources")
+    endif()
     set(lua_output_name "hwlua")
     add_subdirectory(misc/liblua)
     list(APPEND pascal_flags "-XLAlua=${lua_output_name}" "-dLUA_INTERNAL")
@@ -185,7 +187,9 @@
         message(FATAL_ERROR "Missing PhysFS! Rerun cmake with -DPHYSFS_SYSTEM=off to build the internal version")
     endif()
 else()
-    message(STATUS "PhysFS will be provided by the bundled sources")
+    if (NOT PHYSFS_LIBRARY OR NOT PHYSFS_INCLUDE_DIR)
+        message(STATUS "PhysFS will be provided by the bundled sources")
+    endif()
     set(physfs_output_name "hwphysfs")
     add_subdirectory(misc/libphysfs)
     #-XLA is a beta fpc flag that renames libraries before passing them to the linker