hedgewars/CMakeLists.txt
changeset 2213 bd51bbf06033
parent 2203 6bd39d75e0dd
child 2219 07f5345ecae7
--- a/hedgewars/CMakeLists.txt	Mon Jun 29 23:03:25 2009 +0000
+++ b/hedgewars/CMakeLists.txt	Tue Jun 30 12:31:32 2009 +0000
@@ -107,6 +107,10 @@
 	message(FATAL_ERROR "No Pascal compiler found!")
 endif (NOT pascal_compiler)
 
+#special handling of MSVC compiler (no static linking)
+if(MSVC)
+	set(pascal_compiler_flags "-dMSVC" ${pascal_compiler_flags})
+endif(MSVC)
 
 IF(NOT APPLE OR NOT universal_build MATCHES "1")
 #here is the standard command for any system