CMakeLists.txt
branchwebgl
changeset 9273 bd95c9db4f0f
parent 9246 75f430ebeb74
child 9282 92af50454cf2
--- a/CMakeLists.txt	Wed Jun 19 00:07:31 2013 +0200
+++ b/CMakeLists.txt	Wed Jun 19 00:26:13 2013 +0200
@@ -30,11 +30,8 @@
 option(BUILD_ENGINE_LIBRARY "Enable hwengine library (off)" OFF)
 option(ANDROID "Enable Android build (off)" OFF)
 
-if(UNIX AND NOT APPLE)
-    option(MINIMAL_FLAGS "Respect system flags as much as possible (off)" OFF)
-else()
-    option(NOAUTOUPDATE "Disable OS X Sparkle update checking" OFF)
-endif()
+option(MINIMAL_FLAGS "Respect system flags as much as possible (off)" OFF)
+option(NOAUTOUPDATE "Disable OS X Sparkle update checking (off)" OFF)
 
 option(WEBGL "Enable WebGL build (implies NOPASCAL) [default: off]" OFF)
 option(NOPASCAL "Compile hwengine as native C [default: off]" ${WEBGL})
@@ -95,6 +92,7 @@
     set(CMAKE_CXX_FLAGS_DEBUG "-Wall")
 endif()
 
+
 #parse additional parameters
 if(FPFLAGS)
     add_flag_prepend(CMAKE_Pascal_FLAGS ${FPFLAGS})