tools/CMakeLists.txt
changeset 5188 d0461bd6d45b
parent 5169 e353ca78d28b
child 6089 adc69bbb24e5
--- a/tools/CMakeLists.txt	Fri Apr 29 02:42:46 2011 +0200
+++ b/tools/CMakeLists.txt	Fri Apr 29 03:31:50 2011 +0200
@@ -17,6 +17,12 @@
         if(NOT NOAUTOUPDATE)
 		#needed for SPARKLE_FOUND variable
 		find_package(Sparkle QUIET)
+		#needed because the 'if' clause in the script prints silly policy warnings
+		if(${SPARKLE_FOUND})
+			set(SPARKLE_FOUND 1)
+		else()
+			set(SPARKLE_FOUND 0)
+		endif()
 	endif()
 
 	#use the associated tool from the libraries we've selected