misc/liblua/CMakeLists.txt
changeset 7031 d5ea24399a48
parent 5171 f9283dc4860d
child 7262 33e703cc7a7f
--- a/misc/liblua/CMakeLists.txt	Mon May 07 11:59:09 2012 +0200
+++ b/misc/liblua/CMakeLists.txt	Mon May 07 14:53:08 2012 +0200
@@ -1,19 +1,17 @@
+#this file is included only when system Lua library is not found
+
 file(GLOB lua_src *.c *.h)
 set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH})
 
-IF(APPLE)
-	set(build_type STATIC)
-	add_definitions(-DLUA_USE_LINUX)
-	add_library (lua ${build_type} ${lua_src})
-ENDIF(APPLE)
+if(WIN32)
+    add_definitions(-DLUA_BUILD_AS_DLL)
+    add_library(lua SHARED ${lua_src})
 
-IF(WIN32)
-	set(build_type SHARED)
-	add_definitions(-DLUA_BUILD_AS_DLL)
-	add_library (lua ${build_type} ${lua_src})
-
-	SET_TARGET_PROPERTIES(lua PROPERTIES PREFIX "")
-	install(TARGETS lua RUNTIME DESTINATION ${target_dir})
+    set_target_properties(lua PROPERTIES PREFIX "")
+    install(TARGETS lua RUNTIME DESTINATION ${target_dir})
+else(WIN32)
+    add_definitions(-DLUA_USE_LINUX)
+    add_library(lua STATIC ${lua_src})
 endif(WIN32)