QTfrontend/CMakeLists.txt
changeset 8659 e49056d3aba1
parent 8646 e31044b7fbba
child 8666 1652c1d9adc8
--- a/QTfrontend/CMakeLists.txt	Wed Mar 06 01:24:59 2013 +0100
+++ b/QTfrontend/CMakeLists.txt	Wed Mar 06 01:28:21 2013 +0100
@@ -175,6 +175,8 @@
             list(APPEND hwfr_src util/platform/AutoUpdater.cpp
                                  util/platform/SparkleAutoUpdater.mm)
             list(APPEND HW_LINK_LIBS ${SPARKLE_LIBRARY})
+        else()
+            message(FATAL_ERROR "Missing Sparkle! Rerun cmake with -DNOAUTOUPDATE=on to disable autoupdating")
         endif()
     endif()
 endif()