gameServer/CMakeLists.txt
changeset 2606 ed687a8d081f
parent 2409 dbf195c3e09c
child 3452 8c04583d8e2a
--- a/gameServer/CMakeLists.txt	Fri Nov 06 18:24:55 2009 +0000
+++ b/gameServer/CMakeLists.txt	Fri Nov 06 18:59:43 2009 +0000
@@ -30,20 +30,7 @@
 	-odir ${CMAKE_CURRENT_BINARY_DIR}
 	-hidir ${CMAKE_CURRENT_BINARY_DIR})
 
-if(OPTIMIZATIONS)
-set(ghc_flags
-	-w
-	-O2
-	${ghc_flags}
-)
-else(OPTIMIZATIONS)
-set(ghc_flags
-	-Wall
-	-debug
-	-dcore-lint
-	${ghc_flags}
-)
-endif(OPTIMIZATIONS)
+set(ghc_flags ${haskell_compiler_flags_cmn} ${ghc_flags})
 
 add_custom_command(OUTPUT "${EXECUTABLE_OUTPUT_PATH}/hedgewars-server${CMAKE_EXECUTABLE_SUFFIX}"
 		COMMAND "${ghc_executable}"