CMakeLists.txt
branchcmake_pascal
changeset 8787 f9dc079f2aa6
parent 8784 c11727e5fa3f
child 8796 8ab4ef8b70f6
--- a/CMakeLists.txt	Tue Mar 19 10:43:45 2013 +0100
+++ b/CMakeLists.txt	Tue Mar 19 10:55:10 2013 +0100
@@ -257,7 +257,6 @@
 #get BUILD_TYPE and enable/disable optimisation
 message(STATUS "Using ${CMAKE_BUILD_TYPE} configuration")
 if(CMAKE_BUILD_TYPE MATCHES "DEBUG")
-
     list(APPEND haskell_flags "-Wall"       # all warnings
                               "-debug"      # debug mode
                               "-dcore-lint" # internal sanity check
@@ -267,8 +266,6 @@
                               )
 endif()
 
-include(${CMAKE_MODULE_PATH}/utils.cmake)
-
 #lua discovery
 find_package(Lua)
 if(LUA_FOUND)
@@ -276,8 +273,6 @@
 else()
     message(STATUS "LUA will be provided by the bundled sources")
     add_subdirectory(misc/liblua)
-    #linking with liblua.a requires system readline
-    add_flag_append(CMAKE_Pascal_FLAGS "-k${EXECUTABLE_OUTPUT_PATH}/lib${LUA_LIBRARY}.a -k-lreadline")
 endif()