--- a/openalbridge/CMakeLists.txt Sun Jun 28 16:44:04 2009 +0000
+++ b/openalbridge/CMakeLists.txt Sun Jun 28 16:54:51 2009 +0000
@@ -3,8 +3,15 @@
include_directories(${OPENAL_INCLUDE_DIR})
include_directories(${OGGVORBIS_INCLUDE_DIRS})
+#set flag configuration for build type
+set(CMAKE_C_FLAGS "-Wall -pipe")
+set(CMAKE_C_FLAGS_RELEASE "-w -O2 -fomit-frame-pointer")
+set(CMAKE_C_FLAGS_DEBUG "-O0 -g -DDEBUG")
+#set destination directory for library
set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH})
+
+#list of source files for libraries
set(openal_src
openalwrap.c loaders.c endianness.c wrappers.c
)
@@ -12,9 +19,8 @@
#build a static library for human systems
set (build_type STATIC)
-
if(WIN32)
-#workaround for visualstudio
+#workaround for visualstudio (wants headers in the source list)
set(openal_src
openalwrap.h loaders.h endianness.h wrappers.h winstdint.h ${openal_src}
)
@@ -27,6 +33,7 @@
set (build_type SHARED)
endif(WIN32)
+#compiles and links actual library
add_library (openalbridge ${build_type} ${openal_src})
if(WIN32)