--- a/share/hedgewars/Data/Fonts/CMakeLists.txt Thu Jan 16 17:18:53 2014 +0100
+++ b/share/hedgewars/Data/Fonts/CMakeLists.txt Thu Jan 16 19:50:18 2014 +0100
@@ -1,4 +1,26 @@
-install(FILES
+set(FONTFILES
DejaVuSans-Bold.ttf
- wqy-zenhei.ttc
- DESTINATION ${SHAREPATH}Data/Fonts)
+ wqy-zenhei.ttc)
+
+if (FONTS_DIRS)
+ foreach(fontfile ${FONTFILES})
+ set(missing 1)
+ foreach(fontdir ${FONTS_DIRS})
+ if (EXISTS "${fontdir}/${fontfile}")
+ message(STATUS "Fonts: Found ${fontfile} in ${fontdir}")
+ set(missing 0)
+ break()
+ endif()
+ endforeach(fontdir)
+ if(missing)
+ set(MISSINGFONTFILES ${MISSINGFONTFILES} ${fontfile})
+ message(STATUS "Fonts: Could not find ${fontfile}, it will be installed")
+ endif()
+ endforeach(fontfile)
+else()
+ set(MISSINGFONTFILES ${FONTFILES})
+endif()
+
+if (MISSINGFONTFILES)
+ install(FILES ${MISSINGFONTFILES} DESTINATION ${SHAREPATH}Data/Fonts)
+endif()