qmlfrontend/CMakeLists.txt
branchui-scaling
changeset 15288 c4fd2813b127
parent 15052 773beead236f
--- a/qmlfrontend/CMakeLists.txt	Wed May 16 18:22:28 2018 +0200
+++ b/qmlfrontend/CMakeLists.txt	Wed Jul 31 23:14:27 2019 +0200
@@ -8,6 +8,18 @@
 
 find_package(Qt5 COMPONENTS Core Quick REQUIRED)
 
-add_executable(${PROJECT_NAME} "main.cpp" "qml.qrc")
+add_executable(${PROJECT_NAME} "main.cpp" "qml.qrc"
+    "hwengine.cpp" "hwengine.h"
+    "game_config.cpp" "game_config.h"
+    "game_view.cpp" "game_view.h"
+    "team.cpp" "team.h"
+    "engine_instance.cpp" "engine_instance.h"
+    "preview_image_provider.cpp" "preview_image_provider.h"
+    "engine_interface.h"
+    "preview_acceptor.cpp" "preview_acceptor.h"
+    "net_session.cpp" "net_session.h"
+    "players_model.cpp" "players_model.h"
+    "rooms_model.cpp" "rooms_model.h"
+    )
 
-target_link_libraries(${PROJECT_NAME} Qt5::Core Qt5::Quick)
+target_link_libraries(${PROJECT_NAME} Qt5::Core Qt5::Network Qt5::Quick)