QTfrontend/CMakeLists.txt
changeset 10015 4feced261c68
parent 9961 c18c66d621e5
parent 9984 84835d0ceb64
child 10109 91d126fbd7bd
--- a/QTfrontend/CMakeLists.txt	Sun Jan 19 00:18:28 2014 +0400
+++ b/QTfrontend/CMakeLists.txt	Tue Jan 21 22:38:13 2014 +0100
@@ -63,7 +63,7 @@
 include_directories(${SDLMIXER_INCLUDE_DIR})
 include_directories(BEFORE ${PHYSFS_INCLUDE_DIR})
 include_directories(BEFORE ${PHYSLAYER_INCLUDE_DIR})
-
+include_directories(${LUA_INCLUDE_DIR}) #brought by physlayer hwpacksmounter.h
 
 if(UNIX)
     # HACK: in freebsd cannot find iconv.h included via SDL.h
@@ -215,6 +215,10 @@
         )
 endif()
 
+if(CMAKE_CXX_COMPILER MATCHES "clang*")
+    list(APPEND HW_LINK_LIBS stdc++ m)
+endif()
+
 target_link_libraries(hedgewars ${HW_LINK_LIBS})