hedgewars/CMakeLists.txt
changeset 8535 6652a8c8ce89
parent 8518 24d2bdc6deff
child 8528 ffd71e99a4f0
--- a/hedgewars/CMakeLists.txt	Thu Feb 21 01:37:04 2013 +0400
+++ b/hedgewars/CMakeLists.txt	Thu Feb 21 11:12:42 2013 +0400
@@ -146,6 +146,10 @@
 
         list(APPEND pascal_flags "-k${SDLMAIN_LIB}")
     endif()
+
+    #when you have multiple ld installation make sure you get the one bundled with the compiler
+    get_filename_component(compiler_dir ${CMAKE_C_COMPILER} PATH)
+    list(APPEND pascal_flags "-FD${compiler_dir}")
 endif(APPLE)
 
 if(NOT NOPNG)