--- a/CMakeLists.txt Wed May 23 01:39:31 2012 +0200
+++ b/CMakeLists.txt Wed May 23 01:53:25 2012 +0200
@@ -152,7 +152,8 @@
separate_arguments(fpflags_full UNIX_COMMAND ${FPFLAGS})
set(pascal_flags ${fpflags_full} "-B" "-FE../bin" "-Cs2000000" "-vewn" ${pascal_flags})
-set(haskell_flags "-O2" ${haskell_flags})
+separate_arguments(ghflags_full UNIX_COMMAND ${GHFLAGS})
+set(haskell_flags "-O2" ${haskell_flags} ${ghflags_full})
if(Optz)
# set(pascal_flags "-O3" "-OpPENTIUM4" "-CfSSE3" "-Xs" "-Si" ${pascal_flags})
@@ -173,7 +174,11 @@
if(WITH_SERVER)
- find_program(ghc_executable ghc)
+ if(GHC)
+ set(ghc_executable ${GHC})
+ else()
+ find_program(ghc_executable ghc)
+ endif()
if(ghc_executable)
set(HAVE_NETSERVER true)