--- a/openalbridge/CMakeLists.txt Mon Jul 06 11:37:03 2009 +0000
+++ b/openalbridge/CMakeLists.txt Mon Jul 06 22:46:33 2009 +0000
@@ -19,8 +19,8 @@
#build a static library for human systems
set (build_type STATIC)
-#visualstudio doesn't like static linking, so we're building a shared library just for it
-if(MSVC)
+#visualstudio and windows in general doesn't like static linking, so we're building the library in shared mode
+if(WIN32)
#workaround for visualstudio (wants headers in the source list)
set(openal_src
openalwrap.h loaders.h endianness.h wrappers.h globals.h oggvorbis.h ${openal_src}
@@ -32,7 +32,7 @@
link_libraries(${VORBISFILE_LIBRARY})
#build a shared library
set (build_type SHARED)
-endif(MSVC)
+endif()
#compiles and links actual library
add_library (openalbridge ${build_type} ${openal_src})