--- a/tools/corrosion/test/hostbuild/CMakeLists.txt Wed Sep 18 14:10:51 2024 +0200
+++ b/tools/corrosion/test/hostbuild/CMakeLists.txt Wed Nov 20 21:37:47 2024 +0100
@@ -1,11 +1,6 @@
-# FIXME: ONly test this when cross-compiling?
-corrosion_tests_add_test(hostbuild "rust-host-program")
+corrosion_tests_add_test(hostbuild "rust-host-program" IS_HOSTBUILD)
set_tests_properties("hostbuild_run_rust-host-program" PROPERTIES PASS_REGULAR_EXPRESSION
"^ok\r?\nHello Rust Hostbuild, I am an external C function"
)
-# Run tests are disabled by default when cross-compiling, however we still want to test hostbuild!
-# So we manually re-enable the test here.
-if(CMAKE_CROSSCOMPILING)
- set_tests_properties("hostbuild_run_rust-host-program" PROPERTIES DISABLED FALSE)
-endif()
+