CMakeLists.txt
changeset 15876 1878d95d6e15
parent 15870 f550a79274fa
child 15884 f9e1a7c8a658
--- a/CMakeLists.txt	Fri Sep 23 02:21:21 2022 +0300
+++ b/CMakeLists.txt	Fri Sep 23 02:45:49 2022 +0300
@@ -165,6 +165,10 @@
 endif()
 
 
+if(GHC_DYNAMIC)
+  list(APPEND haskell_flags "-dynamic")
+endif()
+
 #get BUILD_TYPE and enable/disable optimisation
 message(STATUS "Using ${CMAKE_BUILD_TYPE} configuration")
 if(CMAKE_BUILD_TYPE STREQUAL "Debug")