gameServer/CMakeLists.txt
changeset 2401 2a694ea2a437
parent 2203 6bd39d75e0dd
child 2406 2e757b32991e
--- a/gameServer/CMakeLists.txt	Fri Oct 02 16:49:31 2009 +0000
+++ b/gameServer/CMakeLists.txt	Fri Oct 02 18:44:37 2009 +0000
@@ -1,9 +1,13 @@
 find_program(ghc_executable ghc)
 
-if (NOT ghc_executable)
+if(NOT ghc_executable)
 	message(FATAL_ERROR "Cannot find GHC")
 endif(NOT ghc_executable)
 
+if(APPLE)
+	find_package(GMP REQUIRED)
+endif(APPLE)
+
 set(hwserver_sources
 	OfficialServer/DBInteraction.hs
 	Actions.hs
@@ -29,7 +33,7 @@
 	-odir ${CMAKE_CURRENT_BINARY_DIR}
 	-hidir ${CMAKE_CURRENT_BINARY_DIR})
 
-if( NOT CMAKE_BUILD_TYPE OR CMAKE_BUILD_TYPE MATCHES "Release")
+if(NOT CMAKE_BUILD_TYPE OR CMAKE_BUILD_TYPE MATCHES "Release")
 set(ghc_flags
 	-w
 	-O2