hedgewars/CMakeLists.txt
changeset 8195 37d47f09f981
parent 8188 4c166505e5c8
child 8201 647c5d352bce
--- a/hedgewars/CMakeLists.txt	Mon Dec 03 01:43:52 2012 +0100
+++ b/hedgewars/CMakeLists.txt	Mon Dec 03 01:45:59 2012 +0100
@@ -111,9 +111,7 @@
 find_package(Freepascal)
 
 if (FPC_VERSION VERSION_LESS required_fpc_version)
-    message(FATAL_ERROR "Necessary FPC version not found (required version = ${required_fpc_version})")
-else()
-    message(STATUS "Found FPC: ${FPC_EXECUTABLE} (version ${FPC_VERSION})")
+    message(FATAL_ERROR "Freepascal is too old, minimum version required is ${required_fpc_version}")
 endif()
 
 
@@ -165,9 +163,8 @@
 
 
 #this command is a workaround to some inlining issues present in older FreePascal versions and fixed in 2.6
-if(FPC_VERSION LESS "020600")
+if(FPC_VERSION VERSION_LESS "2.6")
     #under some configurations CMAKE_BUILD_TOOL fails to pass on the jobserver, breaking parallel compilation
-    #TODO: check if this is needed on windows too
     if(UNIX)
         set(SAFE_BUILD_TOOL $(MAKE))
     else()
@@ -254,7 +251,7 @@
 endif()
 
 #this command is a workaround to some inlining issues present in older FreePascal versions and fixed in 2.6
-if((FPC_VERSION LESS "020600") AND (NOVIDEOREC OR NOT ${FFMPEG_FOUND}))
+if((FPC_VERSION VERSION_LESS "2.6") AND (NOVIDEOREC OR NOT ${FFMPEG_FOUND}))
     add_dependencies(${engine_output_name} ENGINECLEAN)
 endif()