misc/libtremor/tremor/Makefile.am
changeset 7697 767d3c4153a1
parent 6045 9a7cc0f29430
child 7849 a12155461b34
--- a/misc/libtremor/tremor/Makefile.am	Thu Sep 20 23:04:10 2012 +0200
+++ b/misc/libtremor/tremor/Makefile.am	Fri Sep 21 00:50:04 2012 +0200
@@ -2,17 +2,19 @@
 
 INCLUDES = -I./
 
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = vorbisidec.pc
+
 lib_LTLIBRARIES = libvorbisidec.la
 
-libvorbisidec_la_SOURCES = mdct.c block.c window.c \
-                        synthesis.c info.c \
+libvorbisidec_la_SOURCES = mdct.c dsp.c info.c misc.c \
                         floor1.c floor0.c vorbisfile.c \
-                        res012.c mapping0.c registry.c codebook.c \
-			sharedbook.c framing.c bitwise.c \
+                        res012.c mapping0.c codebook.c \
+			framing.c bitwise.c \
                         codebook.h misc.h mdct_lookup.h\
-                        os.h mdct.h block.h ivorbisfile.h lsp_lookup.h\
-                        registry.h window.h window_lookup.h\
-                        codec_internal.h backends.h ogg.h \
+                        os.h mdct.h ivorbisfile.h lsp_lookup.h\
+                        window_lookup.h floor_lookup.c \
+                        codec_internal.h ogg.h \
 			asm_arm.h ivorbiscodec.h
 libvorbisidec_la_LDFLAGS = -version-info @V_LIB_CURRENT@:@V_LIB_REVISION@:@V_LIB_AGE@
 
@@ -27,6 +29,8 @@
 
 include_HEADERS = ivorbiscodec.h ivorbisfile.h ogg.h os_types.h config_types.h
 
+EXTRA_DIST = vorbisidec.pc.in
+
 example:
 	-ln -fs . vorbis
 	$(MAKE) ivorbisfile_example