CMakeLists.txt
branch0.9.19
changeset 9081 7f04ad2cda54
parent 9068 3401390f03cf
child 9086 77f471657230
--- a/CMakeLists.txt	Sun Apr 21 01:36:08 2013 +0200
+++ b/CMakeLists.txt	Wed May 29 22:52:37 2013 +0400
@@ -211,6 +211,10 @@
 
 #set default flags values for all projects (unless MINIMAL_FLAGS is true)
 if(NOT ${MINIMAL_FLAGS})
+    if(WINDOWS)
+        #this flags prevents a few dll hell problems
+        set(CMAKE_C_FLAGS "-static-libgcc ${CMAKE_C_FLAGS}")
+    endif(WINDOWS)
     set(CMAKE_C_FLAGS "-pipe ${CMAKE_C_FLAGS}")
     set(CMAKE_C_FLAGS_RELEASE "-w -Os -fomit-frame-pointer ${CMAKE_C_FLAGS_RELEASE}")
     set(CMAKE_C_FLAGS_DEBUG "-Wall -O0 -g -DDEBUG ${CMAKE_C_FLAGS_DEBUG}")