CMakeLists.txt
branchwebgl
changeset 7995 889ad929cc81
parent 7993 5b5083dc6837
child 7999 bb503cd46516
--- a/CMakeLists.txt	Thu Nov 08 14:46:55 2012 +0000
+++ b/CMakeLists.txt	Thu Nov 08 14:51:56 2012 +0000
@@ -53,11 +53,11 @@
 option(NOPNG "Disable screenshoot compression [default: auto]" OFF)
 option(NOVIDEOREC "Disable video recording [default: auto]" OFF)
 
-option(BUILD_ENGINE_LIBRARY "Enable hwengine library [default: off]" OFF)
 option(ANDROID "Enable Android build [default: off]" OFF)
 option(WEBGL "Enable WebGL build (implies NOPASCAL) [default: off]" OFF)
+option(LIBENGINE "Enable hwengine library [default: off]" OFF)
+
 option(NOPASCAL "Compile hwengine as native C [default: off]" ${WEBGL})
-
 option(NOAUTOUPDATE "Disable OS X Sparkle update checking" OFF)
 option(CROSSAPPLE "Enable OSX when not on OSX [default: off]" OFF)
 
@@ -265,8 +265,8 @@
         add_subdirectory(project_files/Android-build)
     endif()
 
-    #TODO: when ANDROID, BUILD_ENGINE_LIBRARY should be set
-    if(NOT (BUILD_ENGINE_LIBRARY OR ANDROID))
+    #TODO: when ANDROID, LIBENGINE should be set
+    if(NOT (LIBENGINE OR ANDROID))
         add_subdirectory(bin)
         add_subdirectory(misc/quazip)
         add_subdirectory(QTfrontend)