misc/physfs/CMakeLists.txt
branchphysfslayer
changeset 7928 88fde28bbda6
parent 7778 3331b30e4ef1
child 8068 b35427506169
--- a/misc/physfs/CMakeLists.txt	Sun Oct 21 01:28:33 2012 +0400
+++ b/misc/physfs/CMakeLists.txt	Sat Nov 03 00:34:35 2012 +0400
@@ -257,21 +257,21 @@
 
 OPTION(PHYSFS_BUILD_STATIC "Build static library" TRUE)
 IF(PHYSFS_BUILD_STATIC)
-    ADD_LIBRARY(physfs-static STATIC ${PHYSFS_SRCS})
-    SET_TARGET_PROPERTIES(physfs-static PROPERTIES OUTPUT_NAME "physfs")
-    SET(PHYSFS_LIB_TARGET physfs-static)
-    SET(PHYSFS_INSTALL_TARGETS ${PHYSFS_INSTALL_TARGETS} ";physfs-static")
+    ADD_LIBRARY(physfs STATIC ${PHYSFS_SRCS})
+    SET_TARGET_PROPERTIES(physfs PROPERTIES OUTPUT_NAME "physfs")
+    SET(PHYSFS_LIB_TARGET physfs)
+    SET(PHYSFS_INSTALL_TARGETS ${PHYSFS_INSTALL_TARGETS} ";physfs")
 ENDIF(PHYSFS_BUILD_STATIC)
 
-OPTION(PHYSFS_BUILD_SHARED "Build shared library" FALSE)
-IF(PHYSFS_BUILD_SHARED)
-    ADD_LIBRARY(physfs SHARED ${PHYSFS_SRCS})
-    SET_TARGET_PROPERTIES(physfs PROPERTIES VERSION ${PHYSFS_VERSION})
-    SET_TARGET_PROPERTIES(physfs PROPERTIES SOVERSION ${PHYSFS_SOVERSION})
-    TARGET_LINK_LIBRARIES(physfs ${OPTIONAL_LIBRARY_LIBS} ${OTHER_LDFLAGS})
-    SET(PHYSFS_LIB_TARGET physfs)
-    SET(PHYSFS_INSTALL_TARGETS ${PHYSFS_INSTALL_TARGETS} ";physfs")
-ENDIF(PHYSFS_BUILD_SHARED)
+#OPTION(PHYSFS_BUILD_SHARED "Build shared library" FALSE)
+#IF(PHYSFS_BUILD_SHARED)
+#    ADD_LIBRARY(physfs SHARED ${PHYSFS_SRCS})
+#    SET_TARGET_PROPERTIES(physfs PROPERTIES VERSION ${PHYSFS_VERSION})
+#    SET_TARGET_PROPERTIES(physfs PROPERTIES SOVERSION ${PHYSFS_SOVERSION})
+#    TARGET_LINK_LIBRARIES(physfs ${OPTIONAL_LIBRARY_LIBS} ${OTHER_LDFLAGS})
+#    SET(PHYSFS_LIB_TARGET physfs)
+#    SET(PHYSFS_INSTALL_TARGETS ${PHYSFS_INSTALL_TARGETS} ";physfs")
+#ENDIF(PHYSFS_BUILD_SHARED)
 
 IF(NOT PHYSFS_BUILD_SHARED AND NOT PHYSFS_BUILD_STATIC)
     MESSAGE(FATAL "Both shared and static libraries are disabled!")