QTfrontend/CMakeLists.txt
changeset 579 94db15de0392
parent 555 0376fdcc6322
child 591 11b40565b851
--- a/QTfrontend/CMakeLists.txt	Mon Aug 20 16:05:59 2007 +0000
+++ b/QTfrontend/CMakeLists.txt	Mon Aug 20 17:49:39 2007 +0000
@@ -33,10 +33,8 @@
 	endif(DEFINED DATA_INSTALL_DIR)
 endif(WIN32 AND NOT UNIX)
 
-configure_file(${hedgewars_SOURCE_DIR}/QTfrontend/main.cpp.in 
-	${hedgewars_SOURCE_DIR}/QTfrontend/main.cpp)
-configure_file(${hedgewars_SOURCE_DIR}/QTfrontend/hwconsts.h.in 
-	${hedgewars_SOURCE_DIR}/QTfrontend/hwconsts.h)
+configure_file(${hedgewars_SOURCE_DIR}/QTfrontend/hwconsts.cpp.in 
+	${hedgewars_SOURCE_DIR}/QTfrontend/hwconsts.cpp)
 
 set(hwfr_src 
 	game.cpp
@@ -66,7 +64,9 @@
 	netudpwidget.cpp
 	chatwidget.cpp
 	binds.cpp
-	SDLs.cpp)
+	SDLs.cpp
+	playrecordpage.cpp
+	hwconsts.cpp)
 
 if (WIN32)
 	set(hwfr_src ${hwfr_src} res/hedgewars.rc)
@@ -96,13 +96,15 @@
 	netudpserver.h
 	netudpwidget.h
 	chatwidget.h
-	SDLs.h)
+	SDLs.h
+	playrecordpage.h)
 
 set(hwfr_hdrs
 	binds.h
 	ui_hwform.h
 	predefteams.h
 	KB.h
+	hwconsts.h
 )
 
 set(hwfr_rez