hedgewars/CMakeLists.txt
changeset 8697 9624836094de
parent 8688 88a6114a318c
child 8702 a28966180a29
--- a/hedgewars/CMakeLists.txt	Fri Mar 08 11:26:47 2013 -0500
+++ b/hedgewars/CMakeLists.txt	Sat Mar 09 00:20:58 2013 +0100
@@ -167,7 +167,8 @@
 
 find_package_or_disable_msg(PNG NOPNG "Screenshots will be saved in BMP")
 if(PNG_FOUND)
-    list(APPEND pascal_flags "-dPNG_SCREENSHOTS")
+    list(REMOVE_AT PNG_INCLUDE_DIR 1) #removing the zlib include path
+    list(APPEND pascal_flags "-dPNG_SCREENSHOTS -Fl${PNG_INCLUDE_DIR}")
 endif()