hedgewars/CMakeLists.txt
changeset 7718 97ba379164ec
parent 7708 95de696e4711
child 7730 2013733f9ca9
--- a/hedgewars/CMakeLists.txt	Thu Sep 27 13:37:10 2012 -0400
+++ b/hedgewars/CMakeLists.txt	Fri Sep 28 18:03:32 2012 +0100
@@ -137,7 +137,6 @@
         find_file(SDLMAIN_LIB libSDLMain.a PATHS ${sdl_dir}/Resources/)
 
         if(SDLMAIN_LIB MATCHES "SDLMAIN_LIB-NOTFOUND")
-            set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH})
             include_directories(${SDL_INCLUDE_DIR})
             add_library (SDLmain STATIC SDLMain.m)
             #add a dependency to the hwengine target
@@ -174,17 +173,17 @@
 if(NOT NOPNG)
     find_package(PNG)
     if(${PNG_FOUND})
-        message(STATUS "PNG screenshots enabled (library found at ${PNG_LIBRARY})")
+        message(STATUS "Found libpng: ${PNG_LIBRARY}")
         set(pascal_flags "-dPNG_SCREENSHOTS" ${pascal_flags})
         if(APPLE)  # need to explictly link with the static lib -- maybe windows too?
             string(REGEX REPLACE "(.*)libpng.*" "\\1" PNG_LIBDIR "${PNG_LIBRARY}")
             set(pascal_flags "-k${PNG_LIBDIR}/libpng.a" ${pascal_flags})
         endif()
     else()
-        message(STATUS "PNG library not found, switching to screenshots in BMP format")
+        message(STATUS "Screenshots will be in BMP format because libpng was not found")
     endif()
 else()
-    message(STATUS "PNG screenshots disabled per user request, using BMP format")
+    message(STATUS "Screenshots will be in BMP format per user request")
 endif()
 
 
@@ -195,12 +194,11 @@
 endif()
 
 
-if(NOT NO_VIDEOREC)
+if(NOT NOVIDEOREC)
     if(${FFMPEG_FOUND})
-        message(STATUS "Compiling with video recording")
+        message(STATUS "Found FFMPEG: ${FFMPEG_LIBRARIES}")
         include_directories(${FFMPEG_INCLUDE_DIR})
         set(pascal_flags "-dUSE_VIDEO_RECORDING" ${pascal_flags})
-        set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH})
         IF (WIN32)
             # there are some problems with linking our avwrapper as static lib, so link it as shared
             add_library(avwrapper SHARED avwrapper.c)
@@ -215,7 +213,7 @@
             add_dependencies(avwrapper ENGINECLEAN)
         endif()
     else()
-        message(STATUS "FFMPEG library not found, video recording will be disabled")
+        message(STATUS "Could NOT find FFMPEG, video recording will be disabled")
     endif()
 else()
     message(STATUS "Video recording disabled by user")