hedgewars/CMakeLists.txt
changeset 2809 b8956af350c1
parent 2804 31c6c36c5d34
child 2812 0a24853de796
--- a/hedgewars/CMakeLists.txt	Sun Feb 14 21:57:47 2010 +0000
+++ b/hedgewars/CMakeLists.txt	Sun Feb 14 23:50:51 2010 +0000
@@ -150,7 +150,11 @@
 	add_library (SDLmain STATIC SDLMain.m)
 #	set_target_properties(SDLmain PROPERTIES COMPILE_FLAGS "-mmacosx-version-min=${minimum_macosx} --sysroot=${CMAKE_OSX_SYSROOT} ")
 
-#these are the dependencies for building a universal binary on Mac OS X
+	#let's tell freepacal where to find libraries
+	message("${CMAKE_SOURCE_DIR}/misc")
+	set(pascal_compiler_flags "-k${CMAKE_SOURCE_DIR}/misc/liblua.a" ${pascal_compiler_flags})
+
+	#these are the dependencies for building a universal binary on Mac OS X
 	foreach (build_arch ${powerpc_build} ${i386_build} ${x86_64_build})
 		set(lipo_args_list "${EXECUTABLE_OUTPUT_PATH}/hwengine.${build_arch}" ${lipo_args_list})
 		add_custom_command(OUTPUT "${EXECUTABLE_OUTPUT_PATH}/hwengine.${build_arch}"