QTfrontend/CMakeLists.txt
changeset 8311 bc18481dca8b
parent 8310 a98c349bc06b
child 8312 9e8781faabab
--- a/QTfrontend/CMakeLists.txt	Tue Dec 18 03:07:45 2012 +0100
+++ b/QTfrontend/CMakeLists.txt	Tue Dec 18 12:04:17 2012 +0100
@@ -138,7 +138,12 @@
 
 if(BUILD_ENGINE_LIBRARY)
     add_definitions(-DHWLIBRARY)
-    set(HW_LINK_LIBS hwengine ${HW_LINK_LIBS})
+    if (WIN32)
+        set (hwlibname ${EXECUTABLE_OUTPUT_PATH}/hwLibrary.dll)
+    else (WIN32)
+        set (hwlibname hwengine)
+    endif (WIN32)
+    set(HW_LINK_LIBS ${hwlibname} ${HW_LINK_LIBS})
     link_directories(${EXECUTABLE_OUTPUT_PATH})
 endif()