share/CMakeLists.txt
changeset 8279 c03d64969112
parent 8146 1fba650c2aa4
child 8283 af97cdbb7713
--- a/share/CMakeLists.txt	Sat Dec 08 20:49:43 2012 -0500
+++ b/share/CMakeLists.txt	Sun Dec 09 16:00:06 2012 +0100
@@ -9,6 +9,14 @@
         set(HEDGEWARS_REVISION ${HEDGEWARS_VERSION})
     endif()
 
+    #silly libav that always brings in VideoDecoderAcceleration, avaible only from 10.6.3
+    if(NOT NOVIDEOREC)
+        find_package(FFMPEG QUIET)
+        if(${FFMPEG_FOUND} AND ${minimum_macosx_version} VERSION_EQUAL "10.6")
+            set(minimum_macosx_version "10.6.3")
+        endif()
+    endif()
+
     configure_file(${hedgewars_SOURCE_DIR}/share/Info.plist.in
                    ${CMAKE_CURRENT_BINARY_DIR}/Info.plist)
     #path here should be Hedgewars.app/Contents/MacOS