tools/CMakeLists.txt
branch0.9.14.1
changeset 4335 c279aeb615df
parent 2641 b08cafb86797
child 4341 46b8791e577f
--- a/tools/CMakeLists.txt	Sun Nov 14 20:06:47 2010 +0100
+++ b/tools/CMakeLists.txt	Sun Nov 14 20:37:55 2010 +0100
@@ -17,7 +17,10 @@
 	find_package(SDL_mixer REQUIRED)
 	find_package(OGGVORBIS REQUIRED)
 	find_package(SPARKLE)
-	find_program(macdeployqt_EXE NAMES macdeployqt macdeployqt-mac)
+
+	#use the associated tool from the libraries we've selected
+	string(REGEX REPLACE "(.*)/include;-.*" "\\1" qt_base_dir "${QT_INCLUDE_DIR}")
+	find_program(macdeployqt_EXE NAMES macdeployqt macdeployqt-mac PATH ${qt_base_dir})
 
 	if(NOT macdeployqt_EXE)
 		message(FATAL_ERROR "The utility macdeployqt is required to create the bundle!")