QTfrontend/CMakeLists.txt
changeset 5188 d0461bd6d45b
parent 5078 3527f0e7bb21
child 5204 e1a5f4d5d86a
--- a/QTfrontend/CMakeLists.txt	Fri Apr 29 02:42:46 2011 +0200
+++ b/QTfrontend/CMakeLists.txt	Fri Apr 29 03:31:50 2011 +0200
@@ -36,6 +36,10 @@
     else()
         set(HEDGEWARS_DATADIR ${CMAKE_INSTALL_PREFIX}/share/)
     endif()
+    #only the cocoa version of qt supports building 64 bit apps
+    if(APPLE AND (CMAKE_OSX_ARCHITECTURES MATCHES "x86_64*") AND (NOT QT_MAC_USE_COCOA))
+        message(FATAL_ERROR "Building the 64 bit version of Hedgewars *requires* the Cocoa variant of QT on Mac OS X")
+    endif()
 endif()